Push to heroku rejected, attached is my error log, I have followed each instruction as the book suggests.kindly can someone help me debug it? thanks guys


$ python manage.py collectstatic --noinput
remote: Traceback (most recent call last):
remote: File “manage.py”, line 9, in
remote: execute_from_command_line(sys.argv)
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/core/management/init.py”, line 353, in execute_from_command_line
remote: utility.execute()
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/core/management/init.py”, line 327, in execute
remote: django.setup()
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/init.py”, line 18, in setup
remote: apps.populate(settings.INSTALLED_APPS)
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/apps/registry.py”, line 115, in populate
remote: app_config.ready()
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/contrib/admin/apps.py”, line 22, in ready
remote: self.module.autodiscover()
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/contrib/admin/init.py”, line 26, in autodiscover
remote: autodiscover_modules(‘admin’, register_to=site)
remote: File “/app/.heroku/python/lib/python2.7/site-packages/django/utils/module_loading.py”, line 50, in autodiscover_modules
remote: import_module(’%s.%s’ % (app_config.name, module_to_search))
remote: File “/app/.heroku/python/lib/python2.7/importlib/init.py”, line 37, in import_module
remote: import(name)
remote: File “/app/.heroku/python/lib/python2.7/site-packages/registration/admin.py”, line 2, in
remote: from django.contrib.sites.models import RequestSite
remote: ImportError: cannot import name RequestSite
remote: ! Error while running ‘$ python manage.py collectstatic --noinput’.
remote: See traceback above for details.
remote: You may need to update application code to resolve this error.
remote: Or, you can disable collectstatic for this application:
remote: $ heroku config:set DISABLE_COLLECTSTATIC=1
remote: https://devcenter.heroku.com/articles/django-assets
remote: ! Push rejected, failed to compile Python app.


Hello Web App actually doesn’t have you run the collectstatic command — it should happen automatically. Have you created your static folder? Instructions are at the end of the “Setting up your static fles for production” section.


Hi, i just did a heroku config:set DISABLE_COLLECTSTATIC=1, and tried to push it, IT WORKED yipee!!
Que: will that command affect my app in the future?


In the Heroku output or in your web app hosted on heroku, did your static files transfer correctly?