Error when running: $ pip install django-registration-redux==1.3


Great book! Having lots of fun writing my first web app.

Ran into a snag installing

$ pip install django-registration-redux==1.3

I was in my venv folder

I received this error in my shell:

Installing collected packages: django-registration-redux


Traceback (most recent call last):

File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/”, line 211, in main

status =, args)

File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/commands/”, line 311, in run


File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/”, line 646, in install


File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/”, line 803, in install

self.move_wheel_files(self.source_dir, root=root)

File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/req/”, line 998, in move_wheel_files


File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/”, line 339, in move_wheel_files

clobber(source, lib_dir, True)

File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/”, line 310, in clobber


File “/Library/Python/2.7/site-packages/pip-7.1.2-py2.7.egg/pip/utils/”, line 71, in ensure_dir


File “/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/”, line 157, in makedirs

mkdir(name, mode)

OSError: [Errno 13] Permission denied: ‘/Library/Python/2.7/site-packages/django_registration_redux-1.3.dist-info’

You are using pip version 7.1.2, however version 9.0.1 is available.

You should consider upgrading via the ‘pip install --upgrade pip’ command.

I’ve tried upgrading my pip but no luck. I do have admin rights so not sure what the issue.

Any help would be appreciated. Tried a search. Found others with same issue but no solution.


So, this line seems to indicate that you weren’t actually in your virtual environment, because it’s trying to install the package outside your directory.

Apologies but are you completely sure you activated the environment? Shows the (venv) on your command line prompt? Send me a screenshot if you’re not sure. :)


nmd. I solved. If anyone else runs into this problem. Update Pip then try. If running into resistance use ‘sudo’.